<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"><![endif]-->
<!--[if IE 7]><html class="no-js lt-ie9 lt-ie8" lang="en-US"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9" lang="en-US"><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<title>Straight Talk | The Deed Is Done! | The  Community Word</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://thecommunityword.com/online/xmlrpc.php" />
<!--[if IE]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The  Community Word &raquo; Feed" href="http://thecommunityword.com/online/feed/" />
<link rel="alternate" type="application/rss+xml" title="The  Community Word &raquo; Comments Feed" href="http://thecommunityword.com/online/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The  Community Word &raquo; Straight Talk | The Deed Is Done! Comments Feed" href="http://thecommunityword.com/online/blog/2018/07/31/straight-talk-the-deed-is-done/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thecommunityword.com\/online\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.11"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sponsors-slideshow-css'  href='http://thecommunityword.com/online/wp-content/plugins/sponsors-slideshow-widget/style.css?ver=2.1.7' type='text/css' media='all' />
<style id='sponsors-slideshow-inline-css' type='text/css'>
#links-slideshow-2 div, #links-slideshow-2 img, #links-slideshow-2-container { width: 100% !important; max-width: 100% !important; }
</style>
<link rel='stylesheet' id='cab_style-css'  href='http://thecommunityword.com/online/wp-content/plugins/custom-about-author/cab-style.css?ver=4.7.11' type='text/css' media='all' />
<link rel='stylesheet' id='rbanner-css-css'  href='http://thecommunityword.com/online/wp-content/plugins/random-banner//css/rbanner.css?ver=4.7.11' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Cantata+One%7CLato%3A300%2C700&#038;ver=4.7.11' type='text/css' media='all' />
<link rel='stylesheet' id='theme_stylesheet-css'  href='http://thecommunityword.com/online/wp-content/themes/magazine_basic_new_new/style.css?ver=4.7.11' type='text/css' media='all' />
<link rel='stylesheet' id='meks-ads-widget-css'  href='http://thecommunityword.com/online/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://thecommunityword.com/online/wp-content/plugins/jetpack/css/jetpack.css?ver=3.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='multicolumn-css'  href='http://thecommunityword.com/online/wp-content/plugins/column-posts/css/cp_multicolumn.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='http://thecommunityword.com/online/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/plugins/sponsors-slideshow-widget/js/jquery.cycle.all.js?ver=2.65'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var email_newsletter_widget_scripts = {"ajax_url":"http:\/\/thecommunityword.com\/online\/wp-admin\/admin-ajax.php","empty_email":"Please write your Email!","saving":"Saving..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/plugins/e-newsletter/email-newsletter-files/js/widget_script.js?ver=4.7.11'></script>
<link rel='https://api.w.org/' href='http://thecommunityword.com/online/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thecommunityword.com/online/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://thecommunityword.com/online/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Bill Knight | Chicago Farmer' href='http://thecommunityword.com/online/blog/2018/07/31/bill-knight-chicago-farmer/' />
<link rel='next' title='Views &#038; Perspectives | Judge Brett Kavanaugh an Outstanding Pick for Supreme Court' href='http://thecommunityword.com/online/blog/2018/07/31/views-perspectives-judge-brett-kavanaugh-an-outstanding-pick-for-supreme-court/' />
<meta name="generator" content="WordPress 4.7.11" />
<link rel="canonical" href="http://thecommunityword.com/online/blog/2018/07/31/straight-talk-the-deed-is-done/" />
<link rel='shortlink' href='http://wp.me/p4vUMk-2vJ' />
<link rel="alternate" type="application/json+oembed" href="http://thecommunityword.com/online/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthecommunityword.com%2Fonline%2Fblog%2F2018%2F07%2F31%2Fstraight-talk-the-deed-is-done%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thecommunityword.com/online/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthecommunityword.com%2Fonline%2Fblog%2F2018%2F07%2F31%2Fstraight-talk-the-deed-is-done%2F&#038;format=xml" />

<!-- Protected by WP-SpamFree v2.1.1.2 :: JS BEGIN -->
<script type="text/javascript" src="http://thecommunityword.com/online/wp-content/plugins/wp-spamfree/js/wpsf-js.php"></script> 
<!-- Protected by WP-SpamFree v2.1.1.2 :: JS END -->


<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style>
#site-title a,#site-description{position:absolute !important;clip:rect(1px 1px 1px 1px);clip:rect(1px, 1px, 1px, 1px)}
#page{background-color:#ffffff}
.entry-meta a,.entry-content a,.widget a{color:#3D97C2}
</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #d8d8d8; background-image: url("http://thecommunityword.com/online/wp-content/themes/magazine_basic_new_new/library/images/solid.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Straight Talk | The Deed Is Done!" />
<meta property="og:url" content="http://thecommunityword.com/online/blog/2018/07/31/straight-talk-the-deed-is-done/" />
<meta property="og:description" content="I did it. Never thought I would. I quit taking the Peoria Journal. I’ve been a reader for decades. Before that, I was a carrier delivering the Peoria Journal Star in the morning to the south of my ..." />
<meta property="article:published_time" content="2018-07-31T17:17:29+00:00" />
<meta property="article:modified_time" content="2018-07-31T03:17:10+00:00" />
<meta property="og:site_name" content="The  Community Word" />
<meta property="og:image" content="http://thecommunityword.com/online/files/2018/02/ROGER-MONROE.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@communityword" />

<style id="custom-css-css">#social #respond{display:none}.colheader{border:none !important;padding:0;width:460px}.columnist{border-bottom:solid 1px #000 !important;border-top:none;border-left:none;border-right:none;font-weight:700 !important;padding:0!important;background:none !important}</style>
</head>

<body class="post-template-default single single-post postid-9655 single-format-standard custom-background left-sidebar">
	<div id="page" class="grid ">
		<header id="header" class="row" role="banner">
			<div class="c12">
				<div id="mobile-menu">
					<a href="#" class="left-menu"><i class="icon-reorder"></i></a>
					<a href="#"><i class="icon-search"></i></a>
				</div>
				<div id="drop-down-search"><form role="search" method="get" id="searchform" class="slide" action="http://thecommunityword.com/online/" >
    <label class="assistive-text" for="site-search">Search for:</label>
    <input type="search" placeholder="Search&hellip;" value="" name="s" id="site-search" />
    </form></div>

								<div class="title-logo-wrapper remove">
										<div class="header-group">
						<h1 id="site-title"><a href="http://thecommunityword.com/online" title="The  Community Word" rel="home">The  Community Word</a></h1>
											</div>
				</div>

									<a href="http://thecommunityword.com/online" title="The  Community Word" rel="home"><img id="header-img" src="http://thecommunityword.com/online/files/2015/05/1441.jpg" width="1183" height="241" alt="" /></a>
					
				<nav id="site-navigation" role="navigation">
					<h3 class="assistive-text">Main menu</h3>
					<a class="assistive-text" href="#primary" title="Skip to content">Skip to content</a>
					<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-3887" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-3887"><a href="http://thecommunityword.com/online">FRONT PAGE</a>
<li id="menu-item-4502" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4502"><a href="http://thecommunityword.com/online/locations/">Get your copy!</a>
<li id="menu-item-3888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3888"><a href="http://thecommunityword.com/online/cwnotes">CW Notes</a>
<li id="menu-item-3874" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3874"><a href="http://thecommunityword.com/online/links/">Ad Deadlines &amp; Publication Dates</a>
<li id="menu-item-3876" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3876"><a href="http://thecommunityword.com/online/rate-card/">Rate card/media kits</a>
</ul></div>				</nav><!-- #site-navigation -->

				<nav id="site-sub-navigation" role="navigation">
					<h3 class="assistive-text">Sub menu</h3>
									</nav><!-- #site-sub-navigation -->
			</div><!-- .c12 -->
		</header><!-- #header.row -->

		<div id="main" class="row">
			<div id="left-nav"></div>
				<div id="secondary" class="c3" role="complementary">
		<aside id="text-9" class="widget widget_text">			<div class="textwidget"><strong>August 2018</strong></div>
		</aside><aside id="search-3" class="widget widget_search"><form role="search" method="get" id="searchform" class="slide" action="http://thecommunityword.com/online/" >
    <label class="assistive-text" for="site-search">Search for:</label>
    <input type="search" placeholder="Search&hellip;" value="" name="s" id="site-search" />
    </form></aside><aside id="text-4" class="widget widget_text"><h3 class="widget-title">About the Community Word</h3>			<div class="textwidget"><p>The Community Word is published monthly and is available free of charge at businesses throughout the Peoria area.</p>
Editor: <a href="mailto:communityword@yahoo.com">Clare Howard</a>.
Group Weblog: <a href="http://thecommunityword.com/online/cwnotes/">CW Notes</a>.
 For information on advertising, visit <a href="http://thecommunityword.com/online/rate-card/">rate card</a>.<br /><br />

Pick up your copy of the Community Word at these <strong><a href="http://thecommunityword.com/online/locations/">LOCATIONS</a></strong>.<br /><br />

<strong>Submission Guidelines</strong>: The Community Word welcomes submissions of opinion articles on any topic. Submissions should be exclusive to Community Word and should be no longer than 500 words.  Authors should submit a brief bio of several sentences to publish with their article. We do not consider anonymous submissions. Send submissions to: <a href="MAILTO:communityword@yahoo.com">communityword@yahoo.com</a> or Community Word, 400 NE Jefferson, #400, Peoria, IL 61603. Community Word also welcomes letters-to-the-editor. Submissions should be no longer than 200 words.

<img src="http://thecommunityword.com/online/files/2015/05/commword.jpg"/><br /></div>
		</aside><aside id="text-10" class="widget widget_text"><h3 class="widget-title">Support Our Advertisers</h3>			<div class="textwidget"><div style="text-align:center"><img src="http://thecommunityword.com/online/files/2018/05/15-300x150.jpg" style="width:230px;"  alt="" /><br />
<img src="/online/files/2018/05/1-1.jpg" style="width:230px" alt="" /><br />
<img src="/online/files/2018/05/2-1.jpg" style="width:230px" alt="" /><br />
<img src="/online/files/2018/07/joes.jpg" alt="" />
</div>
</div>
		</aside><aside id="rss-3" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="http://thecommunityword.com/online/cwnotes/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://thecommunityword.com/online/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://thecommunityword.com/online/cwnotes">CW Notes</a></h3><ul><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/07/17/has-riverfront-park-been-saved-for-public-use-not-yet-but-perhaps/'>HAS RIVERFRONT PARK BEEN SAVED FOR PUBLIC USE? NOT YET, BUT PERHAPS</a> <span class="rss-date">July 17, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/06/30/peoria-rally-for-immigration-rights/'>Peoria Rally for Immigration Rights</a> <span class="rss-date">June 30, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/06/27/guest-opinion-if-only-theyd-come-the-right-way/'>Guest Opinion: If only they’d come the right way….</a> <span class="rss-date">June 27, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/06/12/fly-in-and-pancake-breakfast-saturday/'>Fly-in and Pancake Breakfast Saturday</a> <span class="rss-date">June 12, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/05/18/african-american-community-reacts-in-shock-to-police-valor-awards/'>African-American Community Reacts in Shock to Police Valor Awards</a> <span class="rss-date">May 18, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/05/14/league-of-women-voters-welcoming-cities/'>League of Women Voters: Welcoming Cities</a> <span class="rss-date">May 14, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/05/09/peoria-to-palestine-welcome-to-the-occupation/'>Peoria to Palestine: Welcome to the Occupation</a> <span class="rss-date">May 9, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/04/23/peoria-aclu-keynote-speaker-on-civil-rights-and-justice/'>PEORIA ACLU-Keynote Speaker on Civil Rights and Justice</a> <span class="rss-date">April 24, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/04/20/100-million-sought-against-peoria-city-and-county-in-heidelberg-lawsuit/'>$100 million settlement sought against Peoria city and county in Heidelberg lawsuit</a> <span class="rss-date">April 20, 2018</span></li><li><a class='rsswidget' href='http://thecommunityword.com/online/cwnotes/2018/04/20/will-trump-push-era-to-victory/'>Will Trump push ERA to victory?</a> <span class="rss-date">April 20, 2018</span></li></ul></aside><aside id="tag_cloud-3" class="widget widget_tag_cloud"><h3 class="widget-title">Tags</h3><div class="tagcloud"><a href='http://thecommunityword.com/online/blog/tag/aaron-schock/' class='tag-link-103 tag-link-position-1' title='5 topics' style='font-size: 8pt;'>Aaron Schock</a>
<a href='http://thecommunityword.com/online/blog/tag/abortion/' class='tag-link-4526 tag-link-position-2' title='8 topics' style='font-size: 12.103448275862pt;'>abortion</a>
<a href='http://thecommunityword.com/online/blog/tag/apollo-theater/' class='tag-link-410 tag-link-position-3' title='5 topics' style='font-size: 8pt;'>Apollo Theater</a>
<a href='http://thecommunityword.com/online/blog/tag/art/' class='tag-link-4542 tag-link-position-4' title='10 topics' style='font-size: 14.275862068966pt;'>Art</a>
<a href='http://thecommunityword.com/online/blog/tag/bill-knight/' class='tag-link-297 tag-link-position-5' title='20 topics' style='font-size: 21.034482758621pt;'>Bill Knight</a>
<a href='http://thecommunityword.com/online/blog/tag/bradley-university/' class='tag-link-208 tag-link-position-6' title='7 topics' style='font-size: 10.896551724138pt;'>Bradley University</a>
<a href='http://thecommunityword.com/online/blog/tag/clare-howard/' class='tag-link-4637 tag-link-position-7' title='13 topics' style='font-size: 16.931034482759pt;'>Clare Howard</a>
<a href='http://thecommunityword.com/online/blog/tag/cleve-heidelberg/' class='tag-link-4843 tag-link-position-8' title='6 topics' style='font-size: 9.6896551724138pt;'>Cleve Heidelberg</a>
<a href='http://thecommunityword.com/online/blog/tag/district-150/' class='tag-link-39 tag-link-position-9' title='5 topics' style='font-size: 8pt;'>District 150</a>
<a href='http://thecommunityword.com/online/blog/tag/donald-trump/' class='tag-link-5502 tag-link-position-10' title='8 topics' style='font-size: 12.103448275862pt;'>Donald Trump</a>
<a href='http://thecommunityword.com/online/blog/tag/doug-and-eileen-leunig/' class='tag-link-4762 tag-link-position-11' title='10 topics' style='font-size: 14.275862068966pt;'>Doug and Eileen Leunig</a>
<a href='http://thecommunityword.com/online/blog/tag/environment/' class='tag-link-175 tag-link-position-12' title='9 topics' style='font-size: 13.310344827586pt;'>environment</a>
<a href='http://thecommunityword.com/online/blog/tag/events/' class='tag-link-216 tag-link-position-13' title='22 topics' style='font-size: 22pt;'>events</a>
<a href='http://thecommunityword.com/online/blog/tag/films/' class='tag-link-397 tag-link-position-14' title='9 topics' style='font-size: 13.310344827586pt;'>films</a>
<a href='http://thecommunityword.com/online/blog/tag/food/' class='tag-link-75 tag-link-position-15' title='5 topics' style='font-size: 8pt;'>food</a>
<a href='http://thecommunityword.com/online/blog/tag/forest-park-nature-center/' class='tag-link-153 tag-link-position-16' title='6 topics' style='font-size: 9.6896551724138pt;'>Forest Park Nature Center</a>
<a href='http://thecommunityword.com/online/blog/tag/gatehouse-media/' class='tag-link-5371 tag-link-position-17' title='6 topics' style='font-size: 9.6896551724138pt;'>GateHouse Media</a>
<a href='http://thecommunityword.com/online/blog/tag/happenings/' class='tag-link-4686 tag-link-position-18' title='7 topics' style='font-size: 10.896551724138pt;'>Happenings</a>
<a href='http://thecommunityword.com/online/blog/tag/journal-star/' class='tag-link-440 tag-link-position-19' title='7 topics' style='font-size: 10.896551724138pt;'>Journal Star</a>
<a href='http://thecommunityword.com/online/blog/tag/labor-roundup/' class='tag-link-4545 tag-link-position-20' title='7 topics' style='font-size: 10.896551724138pt;'>Labor Roundup</a>
<a href='http://thecommunityword.com/online/blog/tag/methodist-medical-center/' class='tag-link-80 tag-link-position-21' title='14 topics' style='font-size: 17.655172413793pt;'>Methodist Medical Center</a>
<a href='http://thecommunityword.com/online/blog/tag/mike-miller/' class='tag-link-4656 tag-link-position-22' title='7 topics' style='font-size: 10.896551724138pt;'>Mike Miller</a>
<a href='http://thecommunityword.com/online/blog/tag/movies/' class='tag-link-418 tag-link-position-23' title='7 topics' style='font-size: 10.896551724138pt;'>movies</a>
<a href='http://thecommunityword.com/online/blog/tag/music/' class='tag-link-289 tag-link-position-24' title='5 topics' style='font-size: 8pt;'>music</a>
<a href='http://thecommunityword.com/online/blog/tag/nature-rambles/' class='tag-link-4689 tag-link-position-25' title='5 topics' style='font-size: 8pt;'>Nature Rambles</a>
<a href='http://thecommunityword.com/online/blog/tag/neighborhoods/' class='tag-link-116 tag-link-position-26' title='5 topics' style='font-size: 8pt;'>neighborhoods</a>
<a href='http://thecommunityword.com/online/blog/tag/op-ed/' class='tag-link-5729 tag-link-position-27' title='6 topics' style='font-size: 9.6896551724138pt;'>Op-Ed</a>
<a href='http://thecommunityword.com/online/blog/tag/peoria/' class='tag-link-332 tag-link-position-28' title='5 topics' style='font-size: 8pt;'>Peoria</a>
<a href='http://thecommunityword.com/online/blog/tag/peoria-park-district/' class='tag-link-4685 tag-link-position-29' title='14 topics' style='font-size: 17.655172413793pt;'>Peoria Park District</a>
<a href='http://thecommunityword.com/online/blog/tag/peoria-public-library/' class='tag-link-4687 tag-link-position-30' title='11 topics' style='font-size: 15.241379310345pt;'>Peoria Public Library</a>
<a href='http://thecommunityword.com/online/blog/tag/peoria-theater/' class='tag-link-389 tag-link-position-31' title='10 topics' style='font-size: 14.275862068966pt;'>Peoria Theater</a>
<a href='http://thecommunityword.com/online/blog/tag/private-parties/' class='tag-link-396 tag-link-position-32' title='6 topics' style='font-size: 9.6896551724138pt;'>Private Parties</a>
<a href='http://thecommunityword.com/online/blog/tag/proctor-hospital/' class='tag-link-101 tag-link-position-33' title='5 topics' style='font-size: 8pt;'>Proctor Hospital</a>
<a href='http://thecommunityword.com/online/blog/tag/racism/' class='tag-link-4525 tag-link-position-34' title='12 topics' style='font-size: 15.965517241379pt;'>racism</a>
<a href='http://thecommunityword.com/online/blog/tag/ray-lahood/' class='tag-link-5515 tag-link-position-35' title='13 topics' style='font-size: 16.931034482759pt;'>Ray LaHood</a>
<a href='http://thecommunityword.com/online/blog/tag/real-talk/' class='tag-link-5474 tag-link-position-36' title='7 topics' style='font-size: 10.896551724138pt;'>Real Talk</a>
<a href='http://thecommunityword.com/online/blog/tag/roger-monroe/' class='tag-link-310 tag-link-position-37' title='13 topics' style='font-size: 16.931034482759pt;'>Roger Monroe</a>
<a href='http://thecommunityword.com/online/blog/tag/schools/' class='tag-link-124 tag-link-position-38' title='5 topics' style='font-size: 8pt;'>schools</a>
<a href='http://thecommunityword.com/online/blog/tag/serendipity/' class='tag-link-4682 tag-link-position-39' title='17 topics' style='font-size: 19.586206896552pt;'>Serendipity</a>
<a href='http://thecommunityword.com/online/blog/tag/sharon-mcbride/' class='tag-link-502 tag-link-position-40' title='10 topics' style='font-size: 14.275862068966pt;'>Sharon McBride</a>
<a href='http://thecommunityword.com/online/blog/tag/straight-talk/' class='tag-link-4679 tag-link-position-41' title='5 topics' style='font-size: 8pt;'>Straight Talk</a>
<a href='http://thecommunityword.com/online/blog/tag/summer/' class='tag-link-214 tag-link-position-42' title='5 topics' style='font-size: 8pt;'>summer</a>
<a href='http://thecommunityword.com/online/blog/tag/theater/' class='tag-link-105 tag-link-position-43' title='6 topics' style='font-size: 9.6896551724138pt;'>theater</a>
<a href='http://thecommunityword.com/online/blog/tag/west-peoria/' class='tag-link-40 tag-link-position-44' title='20 topics' style='font-size: 21.034482758621pt;'>West Peoria</a>
<a href='http://thecommunityword.com/online/blog/tag/west-peoria-news/' class='tag-link-4683 tag-link-position-45' title='10 topics' style='font-size: 14.275862068966pt;'>West Peoria News</a></div>
</aside><aside id="text-5" class="widget widget_text"><h3 class="widget-title">Peoria Portals</h3>			<div class="textwidget"><a href="http://www.peoria.com/"><img src="http://thecommunityword.com/online/files/2015/06/peoria_logo2.png" border="1" align="bottom" vspace="10"/></a><br />

<a href="http://www.explorepeoria.com/"><img src="http://www.thecommunityword.com/ExplorePeoriaSmallLogo.jpg" align="bottom" vspace="10" border="1"/></a>
</div>
		</aside><aside id="metodiew_simple_authors_widget-2" class="widget widget_metodiew_simple_authors_widget"><h3 class="widget-title">Read our writers</h3><ul class="sbaw_authors"><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/admin/" title="View Community Word Staff archive">Community Word Staff (1130)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/amandaknowles/" title="View Amanda Knowles archive">Amanda Knowles (4)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/amrelsamny/" title="View Amr Elsamny archive">Amr Elsamny (3)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/ashleymmiller/" title="View Ashley M. Miller archive">Ashley M. Miller (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/billknight/" title="View Bill Knight archive">Bill Knight (137)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/burtraabe/" title="View Burt Raabe archive">Burt Raabe (2)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/chazstuckey/" title="View Chaz Stuckey archive">Chaz Stuckey (4)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/clarehoward/" title="View Clare Howard archive">Clare Howard (120)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/contributor/" title="View contributor archive">contributor (109)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/curtkeller/" title="View Rev. Dr. Curt Keller archive">Rev. Dr. Curt Keller (4)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/dalegoodner/" title="View Dale Goodner archive">Dale Goodner (52)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/danmontgomery/" title="View Dan Montgomery archive">Dan Montgomery (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/debbieadlof/" title="View Community Word Staff archive">Community Word Staff (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/dougday/" title="View Doug Day archive">Doug Day (18)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/dougleunig/" title="View Doug and Eileen Leunig archive">Doug and Eileen Leunig (25)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/eliidalakota/" title="View Eliida Lakota archive">Eliida Lakota (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/georgehopkins/" title="View George Hopkins archive">George Hopkins (2)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/jillbrockman/" title="View Jill Brockman-Cummings archive">Jill Brockman-Cummings (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/joyceharant/" title="View joyceharant archive">joyceharant (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/kamarataylor/" title="View Kamara Taylor archive">Kamara Taylor (11)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/kirasflowers/" title="View Kira Santiago archive">Kira Santiago (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/lisanelsonraabe/" title="View Lisa Nelson Raabe archive">Lisa Nelson Raabe (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/lynncox/" title="View Lynn Cox archive">Lynn Cox (40)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/marvinhightower/" title="View Marvin Hightower archive">Marvin Hightower (2)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/maxinewortham/" title="View Rev. Maxine Wortham, PhD archive">Rev. Maxine Wortham, PhD (3)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/mbrown/" title="View Michael Brown archive">Michael Brown (6)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/megan/" title="View Megan Mertens archive">Megan Mertens (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/mikemiller/" title="View Mike Miller archive">Mike Miller (31)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/paulkrainak/" title="View Paul Krainak archive">Paul Krainak (15)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/raylahood/" title="View Ray LaHood archive">Ray LaHood (14)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/rogermonroe/" title="View Roger Monroe archive">Roger Monroe (86)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/sandrapost/" title="View Sandra Dempsey Post archive">Sandra Dempsey Post (117)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/scottshepler/" title="View Scott Shepler archive">Scott Shepler (8)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/sharonmcbride/" title="View Sharon McBride archive">Sharon McBride (88)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/sherrycannon/" title="View Sherry Cannon archive">Sherry Cannon (11)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/sidruckriegel/" title="View Sid Ruckriegel archive">Sid Ruckriegel (9)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/speck/" title="View Greg Speck archive">Greg Speck (7)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/terrabrockman/" title="View terrabrockman archive">terrabrockman (1)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/terrybibo/" title="View Terry Bibo archive">Terry Bibo (8)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/tfinch/" title="View Tammy Finch archive">Tammy Finch (21)</a></li><li class="sbaw_author"><a href="http://thecommunityword.com/online/blog/author/trachtenbarg/" title="View David Trachtenbarg, M.D. archive">David Trachtenbarg, M.D. (17)</a></li></ul></aside><aside id="meta-3" class="widget widget_meta"><h3 class="widget-title">Become a member to comment</h3>			<ul>
						<li><a href="http://thecommunityword.com/online/wp-login.php" id="social_login">Log in</a></li>
			<li><a href="http://thecommunityword.com/online/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://thecommunityword.com/online/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</aside>		<aside id="recent-posts-3" class="widget widget_recent_entries">		<h3 class="widget-title">Recent articles</h3>		<ul>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/un-american-dream-becoming-american-illusion/">UN: American Dream Becoming  American Illusion</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/9687/">9687</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/food-for-justice/">Food for justice</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/donations-needed-journalism-diversity-fund/">Donations Needed: Journalism Diversity Fund</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/native-americans-speak/">“Native Americans Speak”</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/views-perspectives-judge-brett-kavanaugh-an-outstanding-pick-for-supreme-court/">Views &#038; Perspectives | Judge Brett Kavanaugh an Outstanding Pick for Supreme Court</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/straight-talk-the-deed-is-done/">Straight Talk | The Deed Is Done!</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/bill-knight-chicago-farmer/">Bill Knight | Chicago Farmer</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/editorial-weaponizing-free-speech/">Editorial | Weaponizing Free Speech</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/letter-to-the-editor-protecting-coal-ash-not-children/">Letter to the Editor | Protecting coal ash, not children</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/real-talk-youre-not-going-to-take-our-pain-and-make-it-a-novelty/">Real Talk | You’re not going to take our pain and make it a novelty</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/op-ed-if-only-theyd-come-the-right-way/">Op-Ed | If only they’d come the right way &#8230;</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/reflections-from-the-clergy-rescue-children-from-the-caves-of-poverty/">Reflections From The Clergy | Rescue Children from the Caves of Poverty</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/serendipty-vacation-wisdom/">Serendipty | Vacation Wisdom</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/nature-rambles-nature-in-progress-at-former-golf-course/">Nature Rambles | &#8216;Nature in Progress&#8217; at former golf course</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/inland-art-sculpture-walk/">Inland Art | Sculpture Walk</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/arts-beat-august-2018/">Arts Beat | August 2018</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/west-peoria-news-boy-scout-ice-cream-social/">West Peoria News | Boy Scout Ice Cream Social</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/labor-roundup-august-2018/">Labor Roundup | August 2018</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/07/31/art-what-is-it-good-for-big-picture-film-festival/">Art. What Is It Good For? | Big Picture Film Festival</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/06/30/unlearning-bias/">Unlearning bias</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/06/30/ag-studies-good-bad-scary/">Ag studies: good, bad, scary</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/06/30/economic-cost-of-losing-newspapers/">Economic cost of losing newspapers</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/06/30/moms-demand-action-for-gun-sense/">Moms Demand Action for Gun Sense</a>
						</li>
					<li>
				<a href="http://thecommunityword.com/online/blog/2018/06/30/views-perspectives-trumps-actions-and-inaction/">Views &#038; Perspectives | Trump&#8217;s actions and inaction</a>
						</li>
				</ul>
		</aside>		<aside id="mb_featured_posts-2" class="widget mb_featured_posts"><h3 class="widget-title">Featured Posts</h3>	<article id="post-9667" class="c12 widget-post post-9667 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-news-article tag-homeless tag-income-inequality tag-poverty tag-racism">

	    <header>
                <h3 class="post-category"><a href="http://thecommunityword.com/online/blog/category/news/" rel="category tag">Articles</a>, <a href="http://thecommunityword.com/online/blog/category/news/news-article/" rel="category tag">News</a></h3>
                <h1 class="entry-title">
                    <a href="http://thecommunityword.com/online/blog/2018/07/31/un-american-dream-becoming-american-illusion/" title="Permalink to UN: American Dream Becoming  American Illusion" rel="bookmark">
                        UN: American Dream Becoming  American Illusion            </a>    </h1>

    <h2 class="entry-meta">
        by <a href="http://thecommunityword.com/online/blog/author/clarehoward/" title="Posts by Clare Howard" rel="author">Clare Howard</a>&nbsp;&bull;&nbsp;<time class="published" datetime="2018-07-31">July 31, 2018</time>    </h2>
</header>

	    <div class="entry-content">
		    <a href="http://thecommunityword.com/online/blog/2018/07/31/un-american-dream-becoming-american-illusion/"><img width="150" height="150" src="http://thecommunityword.com/online/files/2018/07/20180720_dreamcenter1color-150x150.jpg" class="alignleft wp-post-image" alt="Minnie" /></a><p>A scathing report by the United Nations Human Rights Council on extreme poverty and inequality in America was slammed by UN Ambassador Nikki Haley as “patently ridiculous.” Haley then announced the United States was withdrawing from the UN Human Rights&hellip;</p>
<p class="more-link-p"><a class="more-link" href="http://thecommunityword.com/online/blog/2018/07/31/un-american-dream-becoming-american-illusion/">Read more &rarr;</a></p>
	    </div><!-- .entry-content -->

	    
	</article><!-- #post-9667 --></aside>	</div><!-- #secondary.widget-area -->
	


	<div id="primary" class="c5" role="main">

			<article id="post-9655" class="post-9655 post type-post status-publish format-standard hentry category-columns category-straight-talk">

	    <header>
                <h3 class="post-category"><a href="http://thecommunityword.com/online/blog/category/columns/" rel="category tag">Columns</a>, <a href="http://thecommunityword.com/online/blog/category/columns/straight-talk/" rel="category tag">Straight Talk</a></h3>
                <h1 class="entry-title">
                    Straight Talk | The Deed Is Done!                </h1>

    <h2 class="entry-meta">
        by <a href="http://thecommunityword.com/online/blog/author/rogermonroe/" title="Posts by Roger Monroe" rel="author">Roger Monroe</a>&nbsp;&bull;&nbsp;<time class="published" datetime="2018-07-31">July 31, 2018</time>&nbsp;&bull;&nbsp;<a href="http://thecommunityword.com/online/blog/2018/07/31/straight-talk-the-deed-is-done/#comments">1 Comment</a>    </h2>
</header>

	    <div class="entry-content">
		    <p><div id="attachment_8690" style="width: 159px" class="wp-caption alignright columnist"><img class="size-full wp-image-8690" src="http://thecommunityword.com/online/files/2018/02/ROGER-MONROE.jpg" alt="ROGER MONROE" width="149" height="127" /><p class="wp-caption-text">ROGER MONROE</p></div>I did it. Never thought I would. I quit taking the Peoria Journal. I’ve been a reader for decades. Before that, I was a carrier delivering the Peoria Journal Star in the morning to the south of my North Madison home. In the afternoon I threw the Peoria Journal Transcript on porches of houses to the north, far north of my neighborhood.</p>
<p>Back then the paper was cheap and so were those who paid us in the circulation department. If a customer didn’t pay, the paper made us pay. The paper was thick and filled with news. It was a quality newspaper. At one time, they had Republican and Democrat writers. There was balance of opinions on the editorial page. Chuck Dancey was the best of the best editors and highly regarded. How times have changed and not for the good.</p>
<p>Time was I could pick up the paper, relax and read it. Today, reading it raises my blood pressure and angers my senses. Balance is gone, replaced by hate. The newspaper doesn’t dislike the President of the United States. They hate him. In one edition, they had five stories attacking the man in one form or another. </p>
<p>There are times you can’t read the getting smaller sports section without a “damn the President story” blaming him for million dollar athletes refusing to honor the flag, the country and our veterans. Even the headline writer has to put hatred into his work with headlines like, “Contentious Trump barrels into G-7 summit,” and “Trump claiming victory before the game starts.” The latter headline was dubbed “Analysis,” which was inaccurate and should’ve been tagged “Opinion.” Another opinionated headline was, “Trump tones down rhetoric.” Heck, the newspaper can’t even write an objective headline.</p>
<p>Virtually every story by today’s newspaper writers is filled with personal political views and opinions. Readers are no longer permitted to reach their own conclusions.</p>
<p>The recently dismissed or retired editorial writer Mike Bailey loved trashing the President column after column. All one needed was to see his headline and know it was a “hit” piece.</p>
<p>So why read it. Yes, there are lots of examples and reasons for quitting the paper. The sports section used to be one of the best in the nation. Not anymore. We’re in the middle of the baseball season and scores and standings are now usually in the back of the small section. A recent Saturday edition had a huge boring basketball photo and two of only three front page sports stories were features that should’ve been in back pages. I’m not a golfer, but the 147th British Open should’ve been on the front page, not buried on page 4. Apparently, the sports department has no interest in golf unless it’s their own golf tournament. Meanwhile, the cost gets higher as the paper gets smaller and the writing becomes less interesting and more to the far left. Don’t need it. Don’t want it. I’ll get my news from television. The local stations do an excellent job of reporting local stories and they do it sooner.</p>
<h2>The End of the Trail(s)</h2>
<p>Sorry to say the River Trails Apartment project is dead. Opponents, as few in number as they are, like to take credit, but the city just had too many hoops and bureaucratic obstacles to overcome. Of course, the move of Caterpillar headquarters to Deerfield didn’t help the overly optimistic developer’s confidence either. So, Peoria’s riverfront is left with a dismantled retail failure and green space used by a few who walk and ride as they look across the Illinois River to see bustling retail stores, hotels, and restaurants ringing up robust revenue for East Peoria. On the other hand, Peoria has the tax supported museum and Riverplex, so all is not lost . . . completely.</p>
<h2>Refreshing </h2>
<p>Surfing TV several nights ago, I came upon an awards ceremony. Expecting winners to trash the President and call for ending ICE and border agents, I was surprised, pleasantly surprised. Country singer Carrie Underwood was presented the Disney Humanitarian Award. The presenter listed multiple acts of service and charities she has supported during her career. An impressive and lengthy list it was. I was moved by her acceptance remarks. She mentioned God twice. That probably upset the ACLU. There was no hate, no attacks of the President or the country. How unique. How refreshing.</p>
<h3>QUOTE OF THE MONTH</h3>
<p>“America will never be destroyed from the outside. If we falter and lose our freedoms, it will be because we destroyed ourselves.” &#8211;Abraham Lincoln</p>
<div id="cab-author" class="cab-author">
<div class="cab-author-inner">
<div class="cab-author-image">
					<img alt='' src='http://0.gravatar.com/avatar/0d0a85d83333d404f0d4893a3467df18?s=75&#038;d=identicon&#038;r=r' srcset='http://0.gravatar.com/avatar/0d0a85d83333d404f0d4893a3467df18?s=150&amp;d=identicon&amp;r=r 2x' class='avatar avatar-75 photo' height='75' width='75' /></p>
<div class="cab-author-overlay"></div>
</p></div>
<p> <!-- .cab-author-image --></p>
<div class="cab-author-info">
<div class="cab-author-name">Roger Monroe</div>
</p></div>
<p> <!-- .cab-author-info -->
			</div>
<p> <!-- .cab-author-inner -->
		</div>
<p> <!-- .cab-author-shortcodes --></p>
<span style="clear:both;display:none;"><img src="http://thecommunityword.com/online/wp-content/plugins/wp-spamfree/img/wpsf-img.php" width="0" height="0" alt="" style="border-style:none;width:0px;height:0px;display:none;" /></span>	    </div><!-- .entry-content -->

	        <footer class="entry">
	    	</footer><!-- .entry -->
	
	</article><!-- #post-9655 -->
<br>






<br>

			<div id="posts-pagination">

				<h3 class="assistive-text">Post navigation</h3>

				<div class="previous fl"><a href="http://thecommunityword.com/online/blog/2018/07/31/bill-knight-chicago-farmer/" rel="prev">&larr; Bill Knight | Chicago Farmer</a></div>

				<div class="next fr"><a href="http://thecommunityword.com/online/blog/2018/07/31/views-perspectives-judge-brett-kavanaugh-an-outstanding-pick-for-supreme-court/" rel="next">Views &#038; Perspectives | Judge Brett Kavanaugh an Outstanding Pick for Supreme Court &rarr;</a></div>



			</div><!-- #posts-pagination -->



			
<div id="comments" class="comments-area">

	
			<h2 id="comments-title">
			1 comment for &ldquo;<span>Straight Talk | The Deed Is Done!</span>&rdquo;		</h2>

		<ol class="commentlist">
					<li class="comment even thread-even depth-1">
			<div id="comment-6982" class="comment-body">
				<div class="comment-avatar">
					<img alt='' src='http://1.gravatar.com/avatar/daad9d0697aa2afc86c410c81d35c828?s=60&#038;d=identicon&#038;r=r' srcset='http://1.gravatar.com/avatar/daad9d0697aa2afc86c410c81d35c828?s=120&amp;d=identicon&amp;r=r 2x' class='avatar avatar-60 photo' height='60' width='60' />				</div>
				<div class="comment-content">
					<div class="comment-author">
						Emtronics 					</div>
					<div class="comment-meta">
						August 3, 2018 at 9:53 am					</div>
					<div class="comment-text">
												<p>Why do you say reporting facts on what a moron this president is, is a hit job?  I know sir you are hard bent Right but you can not possibly back the clown circus we have now in the White House.</p>
					</div>
										<div class="reply">
						<a rel='nofollow' class='comment-reply-link' href='http://thecommunityword.com/online/blog/2018/07/31/straight-talk-the-deed-is-done/?replytocom=6982#respond' onclick='return addComment.moveForm( "comment-6982", "6982", "respond", "9655" )' aria-label='Reply to Emtronics'>Reply</a>					</div>
									</div>
			</div>
			</li><!-- #comment-## -->
		</ol><!-- .commentlist -->

		
		
	
	
		<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/online/blog/2018/07/31/straight-talk-the-deed-is-done/#respond" style="display:none;">Cancel reply</a></small></h3>
			<div id="commentform" class="comment-form">
				<iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=66711772&#038;postid=9655&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en-US&#038;jetpack_version=3.6.2&#038;sig=6a1aad89d57ad0e3fe5f005f2940500c2f708bc6#parent=http%3A%2F%2Fthecommunityword.com%2Fonline%2Fblog%2F2018%2F07%2F31%2Fstraight-talk-the-deed-is-done%2F" allowtransparency="false" style="width:100%; height: 430px;border:0px;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
			</div>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments .comments-area -->


		
	</div><!-- #primary.c8 -->



		<div id="tertiary" class="c4 end" role="complementary">
			<aside id="text-7" class="widget widget_text"><h3 class="widget-title">Support our advertisers</h3>			<div class="textwidget"><img src="/online/files/2018/07/No.3.HOI_.211.Student.Color-Ad.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/07/17.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/07/Busey-Digital-August.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/07/whiskey-baron-run.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/07/GlobalVillage-aug-c.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/07/Honda-color3.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/4-1.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/7-1.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/8-1.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/4.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/6.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/8.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/10.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/12.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/13.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/16.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/19.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/3.jpg" style="width:320px" alt="" /><br />
<img src="/online/files/2018/05/20.jpg" style="width:320px" alt="" /></div>
		</aside>		</div><!-- #tertiary.widget-area -->
			</div> <!-- #main.row -->
</div> <!-- #page.grid -->

<footer id="footer" role="contentinfo">

	<div id="footer-content" class="grid ">
		<div class="row">

			<p class="copyright c12">
				<span class="fl">Copyright &copy; 2018 <a href="http://thecommunityword.com/online">The  Community Word</a>. All Rights Reserved.</span>
				<span class="fr"><i class="icon-leaf"></i>Magazine Basic created by <a href="https://themes.bavotasan.com/2008/magazine-basic/">c.bavota</a>.</span>
			</p><!-- .c12 -->

		</div><!-- .row -->
	</div><!-- #footer-content.grid -->

</footer><!-- #footer -->

	<div style="display:none">
	<div class="grofile-hash-map-944b471ef55f48faf5c8ef30b96b8047">
	</div>
	<div class="grofile-hash-map-0d0a85d83333d404f0d4893a3467df18">
	</div>
	<div class="grofile-hash-map-d7df07e57230e96a2a369331d5e20b99">
	</div>
	</div>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/plugins/akismet/_inc/form.js?ver=3.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sbawAjax = {"ajaxurl":"http:\/\/thecommunityword.com\/online\/wp-admin\/admin-ajax.php"};
var sbawAjax = {"ajaxurl":"http:\/\/thecommunityword.com\/online\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/plugins/simple-blog-authors-widget/js/main.js?ver=1.0'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/plugins/wp-advertize-it/javascript/wp-advertize-it.js?ver=0.9.7'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201833'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Augaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.11'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-includes/js/comment-reply.min.js?ver=4.7.11'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/themes/magazine_basic_new_new/library/js/harvey.min.js?ver=4.7.11'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-content/themes/magazine_basic_new_new/library/js/theme.js?ver=4.7.11'></script>
<script type='text/javascript' src='http://thecommunityword.com/online/wp-includes/js/wp-embed.min.js?ver=4.7.11'></script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=66711772&postid=9655&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en-US&jetpack_version=3.6.2&sig=6a1aad89d57ad0e3fe5f005f2940500c2f708bc6#parent=http%3A%2F%2Fthecommunityword.com%2Fonline%2Fblog%2F2018%2F07%2F31%2Fstraight-talk-the-deed-is-done%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=66711772&postid=9655&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en-US&jetpack_version=3.6.2&sig=6a1aad89d57ad0e3fe5f005f2940500c2f708bc6#parent=http%3A%2F%2Fthecommunityword.com%2Fonline%2Fblog%2F2018%2F07%2F31%2Fstraight-talk-the-deed-is-done%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "http:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "http:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='http://stats.wp.com/e-201833.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.6.2',blog:'66711772',post:'9655',tz:'-5',srv:'thecommunityword.com'} ]);
	_stq.push([ 'clickTrackerInit', '66711772', '9655' ]);
</script>
</body>
</html>